Excel Spreadsheets and Graphs

Spreadsheets are useful for making tables and graphs and for doing repeated calculations on a set of data. A blank spreadsheet consists of a number of cells (just blank spaces surrounded by lines to make a little “box”). The cell rows are labeled with numbers while the columns are labeled with letters of the alphabet. Thus Cell A6 is the “box” in Row 6 of Column A, which is the first column. Text, numbers, and formulas of various kinds can be entered in each cell.

Tables

Making a table of, say, the force exerted by a spring as its length is changed requires entering the force values in the cells of one column and the length values in the corresponding rows of an adjacent column. Adding some explanatory text in the cells above each column can complete the table. It is sometimes useful or necessary to adjust row heights and/or column widths to accommodate more or less “stuff” in the cells. Clicking on “Help” in the main toolbar at the top of the screen opens a small window where you can type in your question. In this case type in the words “column width” (without the quotation marks) and click on “Search.” Several options will be displayed, including “Changing column width and row height.” Click on it and get detailed instructions how to make the desired changes. Don’t be afraid to use the help screens in Excel. Most of the time you can find answers to your questions fairly quickly.

Graphs

To make a graph in Excel, first select the data to be graphed by clicking on the upper-left cell of the x-data and dragging the cursor down to the lower-right cell of the y-data. A box should appear around your data and the selected cells will change color. Then select the Insert tab on the main toolbar, click on the Scatter icon, and select the “Scatter with Only Markers” icon from the pull down menu that appears. This icon appears first in the list and shows dots for data points, with no lines joining them. This choice is almost always the best choice for the graphs we make in lab. A graph of the data should appear on the worksheet. In addition, the “Chart Tools” ribbon should appear in the main toolbar. (If your x-values are not adjacent to your y-values, you will need to use the “Select Data” option to add data points to your blank graph. This option appears in the “Chart Tools” ribbon after clicking on the graph.)

If you do something unwanted, immediately stop the operation and click on “Undo” icon near the top-left corner of the Excel window. This icon is a blue arrow that curves to the left. Usually you can escape your predicament and try again.
Now you can add a descriptive title ("Graph 1" or "Exercise 1" is not sufficiently descriptive) to the graph and label the quantities (with their units!) plotted on the horizontal and vertical axes. Clicking on the "Layout" tab in the Chart Tools ribbon at the top of the Excel window will bring up icons labeled "Chart Title" and "Axis Labels", among others. For the chart title, select the "Above Chart" option. A text box for the title will appear. Move your cursor to the text box and type your title. To label the horizontal axis, move your cursor to the "Axis Labels" icon and choose the "Title Below Axis" option for the "Primary Horizontal Axis Title". To label the vertical axis, choose the "Rotated Title" option for the "Primary Vertical Axis Title." In each case, a text box will appear in which you can type the axis label with units. For instance, if a cart velocity is plotted along the y-axis, you would want a label like "Velocity (m/s)". The velocity units should be indicated parentheses after the main label.

You may wish to add other features to your graph, such as legends, gridlines, best-fit curves to match the plotted data, different axis labels, etc. Even the size and aspect ratio of the graph can be changed. Some of these options appear when you right-click on an axis. Others can be accessed from icons under the Design, Layout, and Format tabs in the Chart Tools ribbon. Your best approach is to do some exploring. Only a few of the options will likely be useful to you on a regular basis, but you need to find where they are.

When you print a graph, don’t print the whole spreadsheet. Move the cursor over the graph and click it to highlight the graph. Then using the "Print" command in the drop-down menu under the "File" tab on the main toolbar will print just the graph. Selecting "Landscape Orientation" under "Settings" will make the graph as large as possible while still fitting on one page. Graphs printed for your lab notes should be printed in the landscape orientation. Excel will display a preview that shows exactly how the graph will appear on the paper when it is printed. Make any necessary adjustments, then print the graph by clicking on the printer icon in the top-left hand corner of the print window.

**Making calculations on a set of data**

For example let us say that you have data values in Cells A1 and B1 and you wish to take the product of these two numbers and put the result in Cell C1. In Cell C1 type =A1*B1 (the * symbol indicates multiplication). The "equal" sign tells Excel that a formula is to follow. When you hit "enter," the calculation will be performed and the product displayed in Cell C1. The formula for calculating the number in the cell is still present but hidden behind the number in a sense. If you now change the number in Cell A1, as soon as you enter it, the number in Cell C1 will also change as it re-computes the product with the new number. Suppose that we have one set of numbers in Column A, Rows 1–10, another set of numbers in Column B, Rows 1–10, and that we want to calculate the following products, A1*B1, A2*B2, ..., A10*B10. After typing the product formula into Cell C1, we can click on Cell C1, making a dark outline appear around it. Move the cursor to the bottom right corner of Cell C1 until the cursor morphs into a little + sign. Click and drag down to Cell C10 copying the product formula to successive cells along the way. When you release the click button, the desired products should be displayed in Column C, Rows 1–10.

The symbols used for various mathematical functions are:
* = multiplication / = divide
+ = addition
- = subtraction
^ = powers (need not be integer values)

Use parentheses to make it perfectly clear to Excel what you want to do. The formula \(=A1+B1/C1\) is computed as \(=A1+(B1/C1)\). If you wish to sum A1 and B1, then divide by C1, you need to write it as \(=(A1+B1)/C1\). The operations of multiplying, dividing, and taking powers are done first before adding and subtracting.

Some other useful functions in Excel are:

- \(\text{SUM}(A1:A9)\) = sums the numbers in Cells A1–A9.
- \(\text{AVERAGE}(A1:A9)\) = calculates the average (mean) of the numbers in Cells A1–A9.
- \(\text{STDEV}(A1:A9)\) = calculates the standard deviation, \(\sigma(x)\), of the numbers in Cells A1–A9.
- \(\text{SIN}(A3)\) = assumes that A3 is in radians and calculates the sine of the angle.
- \(\text{COS}(A3)\) = assumes that A3 is in radians and calculates the cosine of the angle.
- \(\text{TAN}(A3)\) = assumes that A3 is in radians and calculates the tangent of the angle.
- \(\text{ASIN}(A6)\) = calculates the angle in radians whose sine is the number in Cell A6.
- \(\text{ACOS}(A6)\) = calculates the angle in radians whose cosine is the number in Cell A6.
- \(\text{ATAN}(A6)\) = calculates the angle in radians whose tangent is the number in Cell A6.
- \(\text{SQRT}(A11)\) = square root of the number in A11.
- \(\text{LN}(A7)\) = natural logarithm of the number in A7.

Note: These functions must be preceded by the “equal” sign in order to be treated as a formula and do a calculation. For example, \(=\text{SQRT}(B9)\) typed into Cell C12 will calculate the square root of the number in cell B9 and record it in Cell C12. If the functions are part of a more complicated formula, then only the leading “equal” sign is required. For example, \(=A2+\text{SIN}(A4)\) typed in Cell B8 will add the number in Cell A2 and the sine of the number in Cell A4 and record it in Cell B8.

**Fitting data with straight lines–only if the data are linear!**

Often in physics the dependence of one variable on another is characterized by a linear relationship, meaning that the variables are related to one another through the equation of a straight line of the form \(y = mx + b\), with \(m\) being the slope and \(b\) the \(y\)-intercept of the graph. The slope and intercept often can be quantities of interest. When several data points, \((x, y)\), are related linearly, how can we calculate the best values of the slope and intercept of the relationship? “Least squares” methods minimize the sum of the squares of the deviations of the fitted line from each of the data points and thus give the “best” values for the slope and intercept of the line.

Excel is capable of doing these kinds of fits quite easily. If you have a graph that appears to be quite linear and thus suitable for fitting with a straight line, you can add a “Trendline” to the graph by moving the cursor over the symbol for one data point on the graph and right clicking on it. A drop-down menu should appear with “Add Trendline” as one of the options. Click on it and choose “Linear”. In the same small window click on the “Options” tab near the top and mark the little box for “Display equation on chart.” Clicking on “OK” will display the “best-fit” line on the graph and
give the equation of the line as well on the graph. You can move the equation with your cursor by clicking and dragging if it obscures some of the data points. You can also add or subtract digits of precision to the numbers given for the slope and intercept by right clicking on the equation after highlighting it with the cursor. In spite of its applications in other disciplines, the $R$ or $R$-squared value is seldom useful in the physical sciences and should not be displayed on the graph.

Finding the “standard error” (basically the standard deviation of the mean) for the slope and intercept values, respectively, is also important, because it gives information regarding how precisely we know the slope and intercept values. Excel can do this using the more advanced Regression feature of least-squares fitting. (In OpenOffice and LibreOffice, the LINDEX function performs the same regression.) In Excel, the following steps are required:

1. Click on the “Data” tab in the Chart Tools ribbon and click on the “Data Analysis” icon in the “Analysis” group on the right.
2. In the pull-down menu that appears, scroll down to the “Regression” option and click on it to highlight it. After choosing OK, the Regression window should appear.
3. To input the $y$-values in the first blank text box, move the cursor to the box and click in it. Now move the cursor to the top of the $y$-data column in your spreadsheet and click and drag down to select the whole set of $y$-values. The corresponding cell numbers should appear in the $y$-value box in the Regression window. Now move the cursor to the box for inputting the $x$-values in the Regression window. Click and drag over the column of $x$-values in your spreadsheet and these cell numbers should appear in the $x$-value box in the Regression window.
4. In the Regression window under “Output options” mark the circle for “Output range.” Move the cursor into the blank space just to the right of “Output range” and click it.
5. Now move the cursor to an empty cell in the leftmost column of your spreadsheet near the bottom and click it. The corresponding cell number will appear in the box. This tells Excel where to put the results of the regression analysis.
6. Now you are ready to click OK in the Regression window. Excel will do the appropriate calculations and display them below and to the right of the cell that you chose for the Output range. The values of interest are displayed in the lower-left corner of the stuff displayed, just to the right of labels, “Intercept” and “X Variable.” The first column to the right of the word “Intercept” shows the value of the $y$-intercept. This value should equal the value in the trendline equation on the graph—a nice check! The next column to the right shows the “standard error”, or uncertainty of the intercept value. In other words, the intercept will have a plus/minus uncertainty given by this standard error. Similarly the first column to the right of “X Variable” shows the value of the slope (which should equal the slope in the trendline equation) and the next column shows the plus/minus uncertainty of the slope value. How does Excel get from X Variable to slope? If you look carefully at the regression output, Excel is calling “slope” the coefficient of the X Variable, which is true in the equation of a straight line. A little awkward, but it works.

It is important to avoid fitting a straight line to data that is definitely curved. In this case, your eye is telling you that your model does not fit the data. Such fits are misleading at best. It is often acceptable to select part of your data that does appear to lie on a straight line and fit those points to a straight line.